# The overall system test suite for PrivateStorageio NixOS configuration.
{ pkgs }:
let
  # Add custom packages as an attribute, so it they only need to be evalutated once.
  # See the comment in `morph/lib/default.nix` for details.
  pkgs' = pkgs.extend (self: super: { ourpkgs = self.callPackage ./pkgs {}; });
in {
  private-storage = pkgs'.nixosTest ./tests/private-storage.nix;
  spending = pkgs'.nixosTest ./tests/spending.nix;
  tahoe = pkgs'.nixosTest ./tests/tahoe.nix;
}