Skip to content
Snippets Groups Projects
  • Tom Prince's avatar
    56372538
    Speed up evaluation of grids by evaluating custom packages once. · 56372538
    Tom Prince authored
    The current code evaluates our custom packages once for each node, which adds
    signifcant amount of time to evaluate a grid. We can reduce this, by adding the
    custom package set as an attribute to the nixpkgs set we pass to morph.
    
    This doesn't change how we refer to those packages, as we continue to expose the
    custom package set as a module attribute.
    
    These are the times to evaluate all three grids (on a partially loaded system),
    when there was nothing new to build:
    
    ```
    before:
    real	2m27.837s
    user	3m35.528s
    sys	0m3.722s
    
    after:
    real	1m12.748s
    user	1m34.047s
    sys	0m3.346s
    ```
    56372538
    History
    Speed up evaluation of grids by evaluating custom packages once.
    Tom Prince authored
    The current code evaluates our custom packages once for each node, which adds
    signifcant amount of time to evaluate a grid. We can reduce this, by adding the
    custom package set as an attribute to the nixpkgs set we pass to morph.
    
    This doesn't change how we refer to those packages, as we continue to expose the
    custom package set as a module attribute.
    
    These are the times to evaluate all three grids (on a partially loaded system),
    when there was nothing new to build:
    
    ```
    before:
    real	2m27.837s
    user	3m35.528s
    sys	0m3.722s
    
    after:
    real	1m12.748s
    user	1m34.047s
    sys	0m3.346s
    ```
system-tests.nix 481 B